在线检测未来函数

通达信红蓝K线主图指标公式

来源:Internet,编辑:股旁网,2011-06-19

VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
BUY:=ZIG(3,10);
SELL:=MA(BUY,2);
DRAWICON(CROSS(BUY,SELL),L-0.1,7);
DRAWICON(CROSS(SELL,BUY),H+0.1,8);
STICKLINE(BUY>SELL AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(BUY>SELL AND O>=C,L,H,0,0),COLORRED;
STICKLINE(BUY < SELL AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE(BUY < SELL AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE(BUY < SELL AND O<=C,C,H,0,1),COLORCYAN;
LJB:=1/WINNER(CLOSE);
{股旁网-股票公式网站 www.GUpang.com}
STICKLINE(LJB >10,L-0.45,L-0.4,-1,1),COLORYELLOW;
平均:=(L+H)/2;
KB:=ZIG(平均,10);
KS:=MA(KB,2);
DRAWICON(CROSS(KB,KS),L-0.2,1);
DRAWICON(CROSS(KS,KB),H+0.2,2);
VAR11:=MA(C,9),COLORRED;
上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK2,COLORRED;
下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWTEXT_FIX(1,0,0,0,'市盈率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.08,0,0,CONST(DYNAINFO(39))),COLORYELLOW;
DRAWTEXT_FIX(1,0.16,0,0,'每股收益(元):'),COLOR0080FF;
DRAWNUMBER_FIX(1,0.29,0,0,CONST(FINANCE(33))),COLOR0080FF;
DRAWTEXT_FIX(1,0.36,0,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.46,0,0,CONST(WINNER(C )*100)),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.05,0,'总股本(万股):'),COLORMAGENTA;
DRAWNUMBER_FIX(1,0.13,0.05,0,CONST(FINANCE(1)/10000)),COLORMAGENTA;
DRAWTEXT_FIX(1,0,0.1,0,'所属板块:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.1,0,HYBLOCK),COLOR0080FF;
DRAWTEXT_FIX(1,0.21,0.1,0,DYBLOCK),COLOR0080FF;

通达信红蓝K线主图指标公式

 

相关文章

博聚网