在线检测未来函数

通达信价升量涨指标公式

来源:Internet,编辑:股旁网,2019-02-12

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,
VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),
IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));
主动:=SUM(主动买盘,0)/SUM(主动卖盘,0)*-1;
低主5:=LLV(主动,5);
动比:=主动-低主5;
高动5:=6/HHV(动比,5);
主动心:=高动5*动比;
K1:=主动心+1-REF(主动心,1)>0;
K2:=主动心+1-REF(主动心,1)<0;
主动心向:=主动心*K1-主动心*K2;
{下面是量价了相合}
FF:=CLOSE-REF(CLOSE,1);
A:=MA(VOL*FF,2);
A0:=MA(VOL*FF,3);
A1:=MA(VOL*FF,5);
A2:=MA(VOL*FF,10);
A3:=MA(VOL*FF,20);
A4:=MA(VOL*FF,30);
B:=A-REF(A,1);
B0:=A0-REF(A0,1);
B1:=A1-REF(A1,1);
B2:=A2-REF(A2,1);
B3:=A3-REF(A3,1);
B4:=A3-REF(A4,1);
量价相合:(B>0)+(B0>0)+(B1>0)+(B2>0)+(B3>0)+(B4>0);
YES:(量价相合>1)*量价相合*(主动心向>1 OR 主动心>60);
IF(YES>=REF(YES,1),量价相合,DRAWNULL),COLORGREEN,LINETHICK2;
IF(YES>=REF(YES,1),YES,DRAWNULL),COLORRED,LINETHICK2;
6,COLORGREEN;
ZSHTL月:"量价相合.量价相合#MONTH";
ZZLKP月:"量价相合.YES#MONTH";
ZSHTL周:"量价相合.量价相合#WEEK";
ZZLKP周:"量价相合.YES#WEEK";

通达信价升量涨指标公式

 

相关文章

博聚网