在线检测未来函数

通达信牛市机票选股指标公式

来源:Internet,编辑:股旁网,2019-03-12

X_1:=EMA((EMA(CLOSE*VOL,3)/EMA(VOL,3)+EMA(CLOSE*VOL,6)/EMA(VOL,6)+EMA(CLOSE*VOL,12)/EMA(VOL,12)+EMA(CLOSE*VOL,24)/EMA(VOL,24))/4,18);
X_2:=1.06*X_1;
X_3:=MA(CLOSE,5);
X_4:=MA(CLOSE,10);
X_5:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;
X_6:=CLOSE>REF(CLOSE,1)*1.098 AND CLOSE=HIGH;
X_7:=REF(COUNT(X_3>X_4,7)>=1 AND (X_3>REF(X_3,1) OR CLOSE>REF(CLOSE,1) OR CLOSE>OPEN),1) AND CROSS(CLOSE,X_3) AND CLOSE>X_2 AND X_3>REF(X_3,1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1)*1.015;
X_8:=MA(CLOSE,20);
X_9:=CLOSE>MA(CLOSE,5);
X_10:=MA(CLOSE,5)>MA(CLOSE,10);
X_11:=CLOSE>MA(CLOSE,10);
X_12:=MA(CLOSE,5)>MA(CLOSE,20);
X_13:=CLOSE>MA(CLOSE,20);
X_14:=REF(X_8,1);
X_15:=X_8>X_14;
X_16:=IF(X_9,10,0-10)+IF(X_10,10,0-10)+IF(X_11,10,0-10)+IF(X_12,10,0-10)+IF(X_13,10,0-10)+IF(X_15,10,0-10);
X_17:=REF(X_16,1)<=0 AND X_16>0;
X_18:=X_16>10 AND X_16>=REF(X_16,1) AND X_16>=REF(X_16,2);
X_19:=X_16=60;
X_20:=X_17 OR X_18 OR X_19;
X_21:=BARSLAST(NOT(X_19));
X_22:=COUNT(REF(CLOSE,1)/REF(CLOSE,2)>1.095,12);
X_23:=X_7 AND X_19=1 AND X_21=1 AND X_22;
X_24:=CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH;
X_25:=REF(CLOSE,1)/REF(CLOSE,2)<=0.96 OR REF(OPEN,1)/REF(CLOSE,1)>=1.05;
X_26:=HIGH/REF(CLOSE,1)>1.041 AND CLOSE>REF(CLOSE,1);
X_27:=X_25 AND X_26;
X_28:=REF(CLOSE,2)/REF(CLOSE,3)<1.099;
X_29:=X_27 AND X_28;
X_30:=COUNT(REF(X_24,3),8) AND X_29;
X_31:=MA(CLOSE,20);
X_32:=CLOSE>MA(CLOSE,5);
X_33:=MA(CLOSE,5)>MA(CLOSE,10);
X_34:=CLOSE>MA(CLOSE,10);
X_35:=MA(CLOSE,5)>MA(CLOSE,20);
X_36:=CLOSE>MA(CLOSE,20);
X_37:=REF(X_31,1);
X_38:=X_31>X_37;
X_39:=IF(X_32,10,0-10)+IF(X_33,10,0-10)+IF(X_34,10,0-10)+IF(X_35,10,0-10)+IF(X_36,10,0-10)+IF(X_38,10,0-10);
X_40:=REF(X_39,1)<=0 AND X_39>0;
X_41:=X_39>10 AND X_39>=REF(X_39,1) AND X_39>=REF(X_39,2);
X_42:=X_39=60;
X_43:=X_40 OR X_41 OR X_42;
X_44:=BARSLAST(NOT(X_42));
X_45:=X_30 AND X_42=1 AND X_44=1;
X_46:=REF(CLOSE,7)/REF(CLOSE,8)>1.095 AND REF(CLOSE,7)>REF(OPEN,7);
X_47:=HIGH/REF(CLOSE,1)>1.031 AND BETWEEN(OPEN/REF(OPEN,7),1.05,0.85);
X_48:=REF(OPEN,1)>REF(MA(CLOSE,5),1) AND REF(CLOSE,1)<REF(MA(CLOSE,10),1) AND REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1);
X_49:=X_46 AND X_47 AND X_48;
X_50:=X_49 AND REF(CLOSE,1)/REF(CLOSE,2)<0.97 AND REF(OPEN,1)>REF(CLOSE,1);
X_51:=X_45 OR X_50;
X_52:=(MIN(CLOSE,OPEN)-LOW)/LOW*100;
X_53:=(MAX(CLOSE,OPEN)-MIN(CLOSE,OPEN))/MIN(CLOSE,OPEN)*100;
X_54:=(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100;
X_55:=X_54>X_53 AND X_54>3 AND X_52<1 AND CLOSE>OPEN;
X_56:=120;
X_57:=MA(CLOSE,X_56);
X_58:=POW(CLOSE-X_57,2);
X_59:=MA(X_58,X_56);
X_60:=SQRT(X_59);
X_61:=X_57+2*X_60;
X_62:=X_57-2*X_60;
X_63:=REF(X_57,1);
X_64:=REF(X_61,1);
X_65:=REF(X_62,1);
X_66:=MA(CLOSE,7);
X_67:=MA(CLOSE,20);
X_68:=MA(CLOSE,30);
X_69:=MA(CLOSE,144);
X_70:=MA(CLOSE,8);
X_71:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_72:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_73:=(LOW-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_74:=REF(CLOSE,1);
X_75:=IF((CLOSE-X_74)*100/X_74>=10-0.01*100/X_74,1,0);
X_76:=HIGH>=HHV(HIGH,20);
X_77:=X_76=1 AND BARSLAST(REF(X_76=1,1))>=2;
X_78:=COUNT(X_76,5)>=1;
X_79:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
X_80:=SUM(IF(CLOSE=REF(CLOSE,1),0,X_79),0);
X_81:=MA(X_80,30);
X_82:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
X_83:=SUM(IF(CLOSE=REF(CLOSE,1),0,X_82),0);
X_84:=X_83;
X_85:=X_84>REF(HHV(X_84,30),1);
X_86:=X_80>X_81;
X_87:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_88:=SMA(X_87,3,1);
X_89:=SMA(X_88,3,1);
X_90:=3*X_88-2*X_89;
X_91:=REF(X_75,1);
X_92:=COUNT(X_91,5)>=1;
X_93:=BARSLAST(CLOSE>1.099*REF(CLOSE,1));
X_94:=IF(CLOSE>REF(CLOSE,X_93),10,0);
X_95:=VOL>REF(VOL,1)*1.9;
X_96:=ATAN((MA(CLOSE,6)/REF(MA(CLOSE,6),1)-1)*100)*58.299999;
X_97:=OPEN<=REF(CLOSE,1) AND X_71<(-2);
X_98:=COUNT(X_97,2)>=1;
X_99:=NOT(REF(CLOSE,3)/REF(CLOSE,4)>1.095 AND REF(CLOSE,2)/REF(CLOSE,3)>1.095 AND OPEN>REF(CLOSE,1) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(HIGH,1)/REF(OPEN,1)>1.03 AND REF(HIGH,1)/REF(CLOSE,2)>1.03);
X_100:=NOT(REF(CLOSE,1)/REF(CLOSE,2)<0.909 AND REF(CLOSE,2)/REF(CLOSE,3)>1.099 AND REF(CLOSE,3)/REF(CLOSE,4)<1.09 AND REF(OPEN,2)>REF(CLOSE,3) AND REF(HIGH,1)/REF(OPEN,1)>1.03);
X_101:=NOT(REF(CLOSE,1)/REF(CLOSE,2)<0.91 AND REF(CLOSE,2)/REF(CLOSE,3)<0.91 AND REF(CLOSE,2)/REF(HIGH,1)>1.03 AND REF(MA(CLOSE,5),1)/REF(MA(CLOSE,10),1)>1.05);
X_102:=NOT(REF(CLOSE,2)/REF(CLOSE,3)>1.099 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(HIGH,1)>REF(CLOSE,2) AND OPEN>REF(OPEN,1));
X_103:=NOT(REF(CLOSE,3)/REF(CLOSE,4)>1.095 AND REF(HIGH,2)>REF(CLOSE,3) AND REF(LOW,2)<REF(OPEN,3) AND REF(CLOSE,3)/REF(CLOSE,4)>1.095 AND REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,2)>1.05 AND OPEN/REF(LOW,2)<0.98);
X_104:=NOT(REF(CLOSE,1)/REF(CLOSE,2)<0.901 AND REF(CLOSE,1)=REF(LOW,1) AND REF(OPEN,2)/REF(CLOSE,3)>1.03 AND REF(OPEN,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,2)/REF(CLOSE,3)>1.09 AND REF(OPEN,2)/REF(LOW,2)>1.05);
X_105:=NOT(REF(CLOSE,2)/REF(CLOSE,3)<0.901 AND REF(CLOSE,3)/REF(CLOSE,4)<0.901 AND REF(CLOSE,4)/REF(CLOSE,5)>1.099 AND REF(OPEN,3)>REF(CLOSE,4) AND REF(CLOSE,3)<REF(OPEN,4) AND REF(OPEN,3)/REF(CLOSE,3)>1.05);
X_106:=NOT(REF(CLOSE,2)/REF(CLOSE,3)<0.901 AND REF(OPEN,1)/REF(CLOSE,2)<0.98 AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,4)/REF(CLOSE,5)>1.095 AND REF(HIGH,3)>REF(CLOSE,4) AND REF(LOW,3)<REF(LOW,4));
X_107:=NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.095 AND REF(CLOSE,5)/REF(CLOSE,6)>1.095 AND REF(OPEN,4)>REF(CLOSE,5) AND REF(CLOSE,3)/REF(CLOSE,4)<0.91 AND REF(CLOSE,2)/REF(CLOSE,3)<0.91 AND REF(OPEN,2)/REF(CLOSE,3)<0.98 AND REF(CLOSE,2)>REF(CLOSE,1));
X_108:=NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.095 AND REF(OPEN,3)/REF(CLOSE,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)/REF(CLOSE,3)<0.91 AND REF(OPEN,1)<REF(CLOSE,2));
X_109:=NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.099 AND REF(OPEN,4)<REF(MA(CLOSE,10),4) AND REF(HIGH,3)/REF(CLOSE,4)>1.03 AND REF(CLOSE,1)/REF(CLOSE,2)<0.95 AND CROSS(REF(MA(CLOSE,5),1),REF(MA(CLOSE,10),1)) AND OPEN/REF(OPEN,4)>1.03);
X_110:=NOT(REF(CLOSE,4)/REF(CLOSE,5)<1.099 AND REF(CLOSE,5)/REF(CLOSE,6)>1.099 AND REF(LOW,1)>REF(CLOSE,5) AND OPEN>REF(CLOSE,5) AND REF(CLOSE,1)/REF(CLOSE,2)>0.96);
X_111:=NOT(COUNT(EVERY(REF(CLOSE,1)/REF(CLOSE,2)>1.09,5),8) AND REF(CLOSE,2)/REF(CLOSE,3)>1.099 AND REF(HIGH,1)/REF(OPEN,1)>1.05 AND REF(CLOSE,1)/REF(CLOSE,2)<0.91);
X_112:=X_92 AND X_71>2.5 AND REF(X_98,1) AND REF(X_71<2.4,1) AND X_68>0 AND X_99 AND X_100 AND X_101 AND X_102 AND X_103 AND X_104 AND X_105 AND X_106 AND X_107 AND X_108 AND X_109 AND X_110 AND X_111;
X_113:=REF(CLOSE,10)/REF(CLOSE,11)>1.099 AND OPEN/REF(OPEN,10)<1.03 AND REF(CLOSE,3)/REF(CLOSE,4)<0.95 AND REF(CLOSE,2)/REF(CLOSE,3)<1.02 AND REF(CLOSE,1)/REF(CLOSE,2)<1.01 AND HIGH/REF(CLOSE,1)>1.041;
X_114:=X_23 OR X_51 OR X_112 OR X_113;
选股:X_114 AND NOT(REF(X_114,1)), ;

通达信牛市机票指标公式

 

相关文章

博聚网