在线检测未来函数

通达信MACD挑战版指标公式

来源:Internet,编辑:股旁网,2019-03-15

RR:=(HHV(MA(MA(C,5)-MA(C,12),1),3)+ABS(LLV(MA(MA(C,5)-MA(C,12),1),3)))/2;
A:=RR/4*4,COLOR0000FF;
B:=RR/4*3,COLORAAAA00;
D:=RR/4*2,COLOR00AA00;
E:=RR/4*1,COLOR00AAAA;
R:=(HHV(MA(MA(C,5)-MA(C,12),1),100)+ABS(LLV(MA(MA(C,5)-MA(C,12),1),100)))/2;
F:=R/4*4,COLOR0000AA;
G:=R/4*3,COLORAAAA00;
K:=R/4*2,POINTDOT,COLOR00AA00;
M:=R/4*1,POINTDOT,COLOR00AAAA;
N:=-R/4*1,POINTDOT,COLOR00AAAA;
P:=-R/4*2,POINTDOT,COLOR00AA00;
S:=-R/4*3,COLORAAAA00;
T:=-R/4*4,COLOR0000AA;
A0:=MA(MA(C,7)-MA(C,48),1);
STICKLINE(C>0,R/4*4,-R/4*4,4,0),COLORAB0099;
STICKLINE(C>0,R/4*3,-R/4*3,4,0),COLORFFA1D9;
STICKLINE(C>0,R/4*2,-R/4*2,4,0),COLORADBEFF;
STICKLINE(C>0,R/4*1,-R/4*1,4,0),COLOR5ACCC5;
STICKLINE(A0>=0,R/4*4,-R/4*4,4,0),COLOR660094;
DRAWBAND(RR/4*4,RGB(200,0,0),0,RGB(0,0,0));
DRAWBAND(RR/4*3,RGB(250,0,200),0,RGB(0,0,0));
DRAWBAND(RR/4*2,RGB(0,250,250),0,RGB(0,0,0));
DRAWBAND(RR/4*1,RGB(150,180,190),0,RGB(0,0,0));
DRAWBAND(-RR/4*4,RGB(0,0,0),0,RGB(200,0,0));
DRAWBAND(-RR/4*3,RGB(0,0,0),0,RGB(250,0,200));
DRAWBAND(-RR/4*2,RGB(0,0,50),0,RGB(0,250,250));
DRAWBAND(-RR/4*1,RGB(0,0,0),0,RGB(150,180,190));
UPLINE:R/4*4,COLOR00FFFF;
A3:STICKLINE(C>0,R/4*3,R/4*3,1,0),COLORFFFF00;
A2:STICKLINE(C>0,R/4*2,R/4*2,1,0),COLORFF00FF;
A1:STICKLINE(C>0,R/4*1,R/4*1,1,0),COLORFFFFFF;
DOWNLINE:-R/4*4,COLOR00FFFF;
A31:STICKLINE(C>0,-R/4*3,-R/4*3,1,0),COLORFFFF00;
A21:STICKLINE(C>0,-R/4*2,-R/4*2,1,0),COLORFF00FF;
A11:STICKLINE(C>0,-R/4*1,-R/4*1,1,0),COLORFFFFFF;
0,COLORFF0000;
操盘线A:A0,LINETHICK2,COLORYELLOW;

通达信MACD挑战版指标公式

 

相关文章

博聚网