在线检测未来函数

通达信神秘线主图指标公式

来源:Internet,编辑:股旁网,2019-03-27

操:=MA(C,5);
神秘线:HHV(操,13)DOTLINE,COLORFFB9CC;
L1:=IF((REF(C,1)-REF(C,2))/REF(C,2)>0.07,1,0);
L2:=IF(C>REF(C,1),1,0);
L3:=IF(H>O AND O>C AND C>L,1,0);
L4:=(REF(VOL,0)-REF(VOL,1))/ REF(VOL,1)*100>30;
L5:=CAPITAL<20000000;
L6:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
假阴线:=IF(L1+L2+L3+L4=4,1,0) AND L5 AND L6>REF(L6,1) AND L4 AND FILTER(REF(C,1)<L AND C>=L AND VOL>=REF(VOL,1),1);DRAWICON(FILTER(L2>=75 AND CROSS(90,L2) AND L3>L4>COST(95)<(COST(99)-COST(1))/20*0.7,25),L*0.97,9);
STICKLINE(假阴线,OPEN,CLOSE,3,0),COLOR8000FF;
DRAWICON(假阴线,L*0.94,9);
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
涨停:= IF(ST, C>=C涨停5, C>=C涨停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);
盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORWHITE;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLOR00AA00;{跌停后回升}
大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(大阳线,OPEN,CLOSE,1,0),COLOR0000AA;
大阴线:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);
STICKLINE(大阴线,OPEN,CLOSE,1,0),COLOR2F4F2F;
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;
假阴:=C<O AND C>REF(C,1);
STICKLINE(假阴,O,C,0.5,0),COLORRED;{假阴柱};
假阳:=C>O AND C<REF(C,1);
STICKLINE(假阳,O,C,0.5,0),COLORGREEN;{假阳柱};
半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(CURRBARSCOUNT<=1,昨半分位,昨半分位,12,0),COLORFF00FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.18,0.06,1,'昨半分位'),LINETHICK5,COLOR00FFFF;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.22,0.06,1,昨半分位);

通达信神秘线主图指标公式

 

相关文章

博聚网