在线检测未来函数

通达信低位横盘主图及选股指标公式

来源:Internet,编辑:股旁网,2019-04-10

HDC:(5,100,30);
R1:=HHV(H,HDC);
R2:=LLV(L,HDC);
R3:=(R1-R2)/R2*100<15;
R4:=HHV(H,20)<=REF(HHV(H,20),9) AND LLV(L,20)>=REF(LLV(L,20),9);
R5:=HHV(H,20)<=REF(HHV(H,10),19) AND LLV(L,20)>=REF(LLV(L,10),19);
RBH:=R3*R4*R5 AND REFX(C>REF(R1,1),1);
FH1:=BARSNEXT(RBH);
FH2:=REFX(R1,FH1);
FH3:=REFX(R2,FH1);
FH4:=MIN(BARSLAST(H>FH2 AND FH1>29),BARSLAST(L<FH3 AND FH1>29));
FH5:=REFX(FH4,FH1);
STICKLINE(FH1<FH5 AND FH1>0,FH2,FH3,8,0),COLORAA0055;
STICKLINE(FH1<FH5 AND FH1>0,FH2,FH2,80,0),COLOR00FFFF;
STICKLINE(FH1<FH5 AND FH1>0,FH3,FH3,8,0),COLOR00FFFF;
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
STICKLINE(C/REF(C,1)>=1.095 AND H=C,O,C,2,0),COLORYELLOW;
XG:RBH,COLORRED,NODRAW;
DRAWICON(RBH,H*1.02,7);
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

{
选股公式:

HDC:=30;
R1:=HHV(H,HDC);
R2:=LLV(L,HDC);
R3:=(R1-R2)/R2*100<15;
R4:=HHV(H,20)<=REF(HHV(H,20),9) AND LLV(L,20)>=REF(LLV(L,20),9);
R5:=HHV(H,20)<=REF(HHV(H,10),19) AND LLV(L,20)>=REF(LLV(L,10),19);
XG:R3*R4*R5 AND REFX(C>REF(R1,1),1);
}

通达信低位横盘主图及选股指标公式

 

相关文章

博聚网